Choose any of these login options:

How to Configure IPv6 BGP as using Link-Local Address

IPv6 - Internet Protocol version 6 is the latest version of the Internet Protocol (IP), the communications protocol that provides an identification and location system for computers on networks and routes traffic across the Internet. Today, IPv6 is no longer a novelty, but a reality, and all the Services Providers already think in how to enable IPv6, and also how to provide services using IPv6, and this generates many discussions and mainly a series of tests, which are all very important.
 
Configuring IPv6 BGP as using Link-Local Address
The document represents a configuration example of IPv6 Multiprotocol BGP peering between two 1941 routers using Link Local Address. Each router's active interface (here Serial 0/0) is configured with a unique link local address by command "ipv6 address {ipv6 address} link-local".
Under BGP configuration mode, the remote router's link-local address is combined with keyword "update-source ". Using link-local addresses requires that the interface for the neighbor be identified by using the update-source command and that a route map be configured to set an IPv6 global next hop. Under the address-family mode, neighbour is activated and a route-map specifying the Next Hop is applied to the neighbour.
Background
In this document, two routers Austin and Dallas are forming EBGP peering over Serial 0/0 interface configured with IPv6 Link-Local addresses (Fe80:1::1 and FE80:2::1). The interfaces are also configured with Global Unicast Address (2012:1:1:1::x/64 in our topology). Austin is residing in AS 100 while the router Dallas in AS 200. Austin is advertising its Loopback 10 address (2012:10:10:10::10/128).
Note: All configurations are tested on Cisco 3745 series router operating on C3745-ADVIPSERVICESK9-M, IOS Version 12.4(15)T14.

Configurations

Austin Dallas
hostname Austin
ip cef
no ip domain lookup
ipv6 unicast-routing
!
interface Loopback10
no ip address
ipv6 address 2012:10:10:10::10/128
!
interface Serial0/0
no ip address
ipv6 address FE80:1::1 link-local
ipv6 address 2012:1:1:1::1/64
ipv6 enable
clock rate 2000000
!
router bgp 100
bgp router-id 1.1.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor FE80:2::1 remote-as 200
neighbor FE80:2::1 update-source Serial0/0
!
address-family ipv6
  neighbor FE80:2::1 activate
  neighbor FE80:2::1 route-map Next-Hop out
  network 2012:10:10:10::10/128
exit-address-family
!
route-map Next-Hop permit 10
set ipv6 next-hop 2012:1:1:1::1
!
end
hostname Dallas
ip cef
no ip domain lookup
!
ipv6 unicast-routing
!
interface Serial0/0
no ip address
ipv6 address FE80:2::1 link-local
ipv6 address 2012:1:1:1::2/64
ipv6 enable
clock rate 2000000
!
router bgp 200
bgp router-id 2.2.2.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor FE80:1::1 remote-as 100
neighbor FE80:1::1 update-source Serial0/0
!
address-family ipv6
  neighbor FE80:1::1 activate
  neighbor FE80:1::1 route-map Next-Hop out
exit-address-family
!
route-map Next-Hop permit 10
set ipv6 next-hop 2012:1:1:1::2
!
end
 
Verification
1.                  show bgp ipv6 unicast summary
2.                  show bgp ipv6 unicast

 
More related:
How to Connect Your Network in IPv6
How to Realize IPv4 over IPv6 on Cisco Devices?
How to Configure IPv6 Static Routing for Cisco Devices?



share on: Share it! Tweet it! Stumble it! Digg it! Email it!  |  Permalink  |  lookafterpp in Cisco router | 2 Comments
Reader Comments  (2)

no photo
no photo
Enrique Richard   | September 18th 2017 at 1505722938

Link-local addresses may be doled out physically by an administrator or by automatic operating system procedures. For Internet Protocol (IP) systems, they are appointed Write my Assignment UK regularly using stateless address auto arrangement.

Post a Comment
Author:
Email:
(Optional)
  
lookafterpp
Reputation: 0 (0%)
Member Since:  Jul 2013
Last activity: 5/13/15, 6:05 pm