Choose any of these login options:

Example for Configuring GVRP on Huawei Router

How to Configuce GVRP for Huawei Router, I use the AR3200 most time on the network, here is the example for you:

Networking Requirements

As shown in Figure 1, company A, a branch of company A, and company B are connected

using switches. To implement dynamic VLAN registration, enable GVRP. The branch of

company A can communicate with the headquarters using RouterA and RouterB. Company B can communicate with company A using RouterB and RouterC. Interfaces connected to company A allow only the VLAN to which company B belongs to pass.

Figure 1 Networking diagram of GVRP configuration



Configuration Roadmap

The configuration roadmap is as follows:

1. Enable GVRP to implement dynamic VLAN registration.

2. Configure GVRP on all switche devices of company A and set the registration mode to

normal for the interfaces to simplify configurations.

3. Configure GVRP on all switche devices of company B and set the registration mode to

fixed for the interfaces connecting to company A to allow only the VLAN to which

company B belongs to pass.

 

Configuration overview

Step 1 Create VLAN 101 to VLAN 200 on RouterA.

system-view

[RouterA] vlan batch 101 to 200

Step 2 Configure GVRP on Router A.

# Enable GVRP globally.

[RouterA] gvrp

# Set the link type of Eth 2/0/1 and Eth 2/0/2 to trunk, and configure the interfaces to allow all

VLANs to pass through.

[RouterA] interface ethernet 2/0/1

[RouterA-Ethernet2/0/1] port link-type trunk

[RouterA-Ethernet2/0/1] port trunk allow-pass vlan all

[RouterA-Ethernet2/0/1] quit

[RouterA] interface ethernet 2/0/2

[RouterA-Ethernet2/0/2] port link-type trunk

[RouterA-Ethernet2/0/2] port trunk allow-pass vlan all

[RouterA-Ethernet2/0/2] quit

# Enable GVRP on the interfaces and set the registration modes for the interfaces.

[RouterA] interface ethernet 2/0/1

[RouterA-Ethernet2/0/1] gvrp

[RouterA-Ethernet2/0/1] gvrp registration normal

[RouterA-Ethernet2/0/1] quit

[RouterA] interface ethernet 2/0/2

[RouterA-Ethernet2/0/2] gvrp

[RouterA-Ethernet2/0/2] gvrp registration normal

[RouterA-Ethernet2/0/2] quit

The configuration of RouterB is similar to that of RouterA.

Step 3 Configure RouterC.

# Create VLAN 101 to VLAN 200.

system-view

[RouterC] vlan batch 101 to 200

# Enable GVRP globally.

[RouterC] gvrp

# Set the link type of Eth 2/0/1 and Eth 2/0/2 to trunk, and configure the interfaces to allow all

VLANs to pass through.

[RouterC] interface ethernet 2/0/1

[RouterC-Ethernet2/0/1] port link-type trunk

[RouterC-Ethernet2/0/1] port trunk allow-pass vlan all

[RouterC-Ethernet2/0/1] quit

[RouterC] interface ethernet 2/0/2

[RouterC-Ethernet2/0/2] port link-type trunk

[RouterC-Ethernet2/0/2] port trunk allow-pass vlan all

[RouterC-Ethernet2/0/2] quit

# Enable GVRP on the interfaces and set the registration modes for the interfaces.

[RouterC] interface ethernet 2/0/1

[RouterC-Ethernet2/0/1] gvrp

[RouterC-Ethernet2/0/1] gvrp registration fixed

[RouterC-Ethernet2/0/1] quit

[RouterC] interface ethernet 2/0/2

[RouterC-Ethernet2/0/2] gvrp

[RouterC-Ethernet2/0/2] gvrp registration normal

[RouterC-Ethernet2/0/2] quit

Step 4 Verify the configuration.

After the configuration is complete, the branch of Company A can communicate with the

headquarters, and users of Company A in VLAN 101 to VLAN 200 can communicate with users in Company B.

Run the display gvrp status command on RouterA to check whether GVRP is enabled globally.

The following information is displayed:

display gvrp status

Info: GVRP is enabled.

Run the display gvrp statistics command on RouterA to view GVRP statistics, including the GVRP state of each interface, number of GVRP registration failures, source MAC address of the last GVRP PDU, and registration mode of each interface.

display gvrp statistics interface ethernet 2/0/1

GVRP statistics on port Ethernet2/0/1

GVRP status : Enabled

GVRP registrations failed : 0

GVRP last PDU origin : 0001-0001-0001

GVRP registration type : Normal

Verify the configurations of RouterB and RouterC in the same way.

----End

Configuration Files

l Configuration file of RouterA

#

sysname RouterA

#

vlan batch 101 to 200

#

gvrp

#

interface ethernet2/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

#

interface ethernet2/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

#

return

l Configuration file of RouterB

#

sysname RouterB

#

gvrp

#

interface ethernet2/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

#

interface ethernet2/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

#

return

l Configuration file of RouterC

#

sysname RouterC

#

vlan batch 101 to 200

#

gvrp

#

interface ethernet2/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

gvrp registration fixed

#

interface ethernet2/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

gvrp

#

Return



share on: Share it! Tweet it! Stumble it! Digg it! Email it!  |  Permalink  |  lookafterpp in Huawei router | Comment on this
Reader Comments

Post a Comment
Author:
Email:
(Optional)
  
lookafterpp
Reputation: 0 (0%)
Member Since:  Jul 2013
Last activity: 5/13/15, 6:05 pm