Choose any of these login options:

Example for Configuring Communication Between VLANs Using VLANIF Interfaces

Huawei AR150&160&200&1200&2200&3200 Series Enterprise Routers Configuration Guide - Example for Configuring Communication Between VLANs Using VLANIF Interfaces
 
Networking Requirements
As shown in Figure 1, Ethernet 2/0/1 of the Router is connected to the uplink interface of SwitchA.
On SwitchA, the downlink interface Ethernet 2/0/1 is added to VLAN 10 and the downlink interface Ethernet 2/0/2 is added to VLAN 20.
PC1 in VLAN 10 and PC2 in VLAN 20 need to communicate with each other
 
Figure 1 Network diagram for communication between VLANs through VLANIF interfaces

Configuration Roadmap
The configuration roadmap is as follows:
1. Add Ethernet interfaces to the VLAN.
2. Configure VLANIF interfaces.
 
Procedure
Step 1 Configure the Router.
# Create VLANs.
system-view
[Huawei] sysname Router
[Router] vlan batch 10 20
# Add interfaces to the VLANs.
[Router] interface ethernet 2/0/1
[Router-Ethernet2/0/1] port link-type trunk
[Router-Ethernet2/0/1] port trunk allow-pass vlan 10 20
[Router-Ethernet2/0/1] quit
# Assign IP addresses to the VLANIF interfaces.
[Router] interface vlanif 10
[Router-Vlanif10] ip address 10.10.10.1 24
[Router-Vlanif10] quit                   
[Router] interface vlanif 20
[Router-Vlanif20] ip address 20.20.20.1 24
[Router-Vlanif20] quit
 
Step 2 Configure SwitchA.
# Create VLANs.
system-view
[Huawei] sysname SwitchA
[SwitchA] vlan batch 10 20
# Add interfaces to the VLANs.
[SwitchA-Ethernet2/0/1] port link-type access
[SwitchA-Ethernet2/0/1] port default vlan 10
[SwitchA-Ethernet2/0/1] quit
[SwitchA] interface ethernet 2/0/2
[SwitchA-Ethernet2/0/2] port link-type access
[SwitchA-Ethernet2/0/2] port default vlan 20
[SwitchA-Ethernet2/0/2] quit
[SwitchA] interface ethernet 2/0/3
[SwitchA-Ethernet2/0/3] port link-type trunk
[SwitchA-Ethernet2/0/3] port trunk allow-pass vlan 10 20
[SwitchA-Ethernet2/0/3] quit
 
Step 3 Verify the configuration.
On PC1 in VLAN 10, configure the default gateway address as the IP address of VLANIF 10 (in this example: 10.10.10.1/24).
On PC2 in VLAN 20, configure the default gateway address as the IP address of VLANIF 20 (in this example: 20.20.20.1/24).
After the configuration is complete, PC1 in VLAN 10 can communicate with PC2 in VLAN 20.
----End
 
Configuration Files
Configuration file of the Router
#
sysname Router
#
vlan batch 10 20
#
interface Vlanif10
ip address 10.10.10.1 255.255.255.0
#
interface Vlanif20
ip address 20.20.20.1 255.255.255.0
#
interface Ethernet2/0/1
port link-type trunk
port trunk allow-pass vlan 10 20
#
return
Configuration file of SwitchA
#
sysname SwitchA
#
vlan batch 10 20
#
interface Ethernet2/0/1
port link-type access
port default vlan 10
#
interface Ethernet2/0/2
port link-type access
port default vlan 20
#
interface Ethernet2/0/3
port link-type trunk
port trunk allow-pass vlan 10 20
#
Return

More related:
Example for Outputting Logs to the Log File
Example for Configuring the PPPoE Client on Huawei AR1200
Example for Configuring Local Port Mirroring to Monitor User Behaviors
How Do I Use the Web System to Log In to the Switch?


 



share on: Share it! Tweet it! Stumble it! Digg it! Email it!  |  Permalink  |  lookafterpp in Huawei router | 5 Comments
Reader Comments  (5)

no photo
Alex Sam   | July 11th 2017 at 1499765705

This document provides the configuration and troubleshooting steps applicable to the creation of Layer 3 interfaces. VLANs divide broadcast domains in a LAN environment. promotional video maker. Whenever hosts in one VLAN need to communicate with hosts in another VLAN, the traffic must be routed between them. This is known as inter-VLAN routing.
no photo
terry   | July 28th 2017 at 1501290842

Longchamp Xiang horse pattern LOGO never low-key details of longchamp outlet the fashion from the big fashion LOGO high-profile behavior, really reminiscent of the Longchamp folding handbag concept dumplings popular and to the already dead Michae tribute is the popular emblem Buttons, with excellent top French traditions, leading fashion design, lightweight and practical folding concept and plain and intimate price world-famous.Longchamp is a French luxury leather goods brand, founded in 1948 by Jean Cassegrain in Paris. Products include leather handbags, luggage, shoes, travel goods, fashion accessories and women's clothing line. Longxiang in more than 80 countries around the world has more than 1,500 retail stores, including more than 300 boutique shops are located in the world-renowned and enjoy the reputation of cheap longchamp bags the street.
no photo
Cherry   | August 8th 2017 at 1502200355

Basically design them to be on two separate subnets. I would recommend doing a little research on TCP/IP and Subnetting. PCs on isolated subnets can't impart on the grounds that the subnets go about as totally unique systems. Check my hotspots for a little further information Click here Complete SEO Services Online
no photo
rahu | August 28th 2017 at 1503909701

Be and also play this solitaire addicted to it. Take on various other game pyramid solitaire gamers as well as attain the highest possible rating amongst solitaire players.
no photo
Anna Warren   | October 6th 2017 at 1507301517

Post a Comment
Author:
Email:
(Optional)
  
lookafterpp
Reputation: 0 (0%)
Member Since:  Jul 2013
Last activity: 5/13/15, 6:05 pm