Choose any of these login options:

How to Configure a Different DHCP Pool on 1921 Router for VLAN 2960 Switch

Question: I have a cisco 1921 router with the LAN interface connected to a Cisco 2960 switch. My 2960 switch is configured to work in VLANs.

What I would like to do is create IP pools for each VLAN in my switch?
This will allow a PC on a VLAN to get an IP in a different subnet as PCs connected in other VLANs.
 
Answer:
First create your dhcp pools on your router :
 
!
ip dhcp pool VLAN10
   network 192.168.10.0 255.255.255.0
   default-router 192.168.10.1
!
ip dhcp pool VLAN20
   network 192.168.20.0 255.255.255.0
   default-router 192.168.20.1
!

 
Don't forget to put the parameters you need and set up exclusions.
Then configure your .1q sub interfaces
 
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto

no shutdown

 !
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!

 
On your switch, create you vlans
vlan 10
vlan 20
 
on your switch configure the port connected to your router as a trunk port
interface f0/0
switchport mode trunk
no shutdown
That should be enough. Refine your config.
 
However, some 2960 platforms allow you to change the SDM template and let the switch act as "limited" layer 3 switch letting you create SVI's for instance and activate IP routing;
 
It’s referred from:
https://supportforums.cisco.com/discussion/12374631/configure-different-dhcp-pool-1921-router-vlan-2960-switch
 
More related:
PAK license for Cisco 1921 router
Comparison between Cisco 1941 and 1921
How to recover Cisco 1921 router default password?



share on: Share it! Tweet it! Stumble it! Digg it! Email it!  |  Permalink  |  cisco2900router in Cisco 1921 | Comment on this
Reader Comments

Post a Comment
Author:
Email:
(Optional)
  
cisco2900router
Reputation: 0 (0%)
Member Since:  Jan 2014
Last activity: 5/18/15, 12:38 am