Choose any of these login options:

Cisco 3750 Port Speed Limit configuration

The speed limit on the port, refers to all the maximum flow control, below is the emample for how to limit speed on Catalyst 3750 port.
A Network specification
PC1 connected to the Cisco 3750 (WS-C3750X-24S-S)F0/1, rate speed is 1M;
PC1 connected to the Cisco 3750 F0/2, rate speed is 2M;
Cisco 3750 G0/1 is the export.
 
B Configuration process
Note: each interface in each direction supports only one strategy; a strategy can be used formultiple interfaces. Therefore all PC download speed limit should be defined in the same policy(in this example: policy -map user-down), and PC to differentiate different rate are defined in the Class-map.
1,  Start QOS on the switch
Switch (config) #mls QoS / / start QOS on the switch
 
2, define PC1 (10.10.1.1) and PC2 (10.10.2.1) access control list
Switch (config) #access-list 10 permit 10.10.1.0 0.0.0.255 / / PC1 upstream flow control
Switch (config) #access-list 100 permit any 10.10.1.0 0.0.0.255 / / PC1 downlink traffic control
Switch (config) #access-list 11 permit 10.10.2.0 0.0.0.255 / / PC2 upstream flow control
Switch (config) #access-list 111 permit any 10.10.2.0 0.0.0.255 / / PC2 downlink traffic control
 
3, classes are defined, and the above definition of access control list is bound
Switch (config class-map user1-up) # / definition of PC1 uplink, and bind the access list 10
Switch (config-cmap) # match access-group 10 
Switch (config-cmap) # exit
Switch (config) # class-map user2-up 
Switch (config-cmap) # match access-group 11 /  definition PC2 uplink, and bind the access list 10
Switch (config-cmap) # exit
Switch(config)# class-map user1-down
Switch (config-cmap) # match access-group 100  / definition of PC1 downlink, and bind theaccess list 100
Switch (config-cmap) # exit
Switch(config)# class-map user2-down
Switch (config-cmap) # match access-group 111  / definition of PC2 downlink, and bind theaccess list 111
Switch (config-cmap) # exit
 
4, the definition of strategy, the above definition class is bound to the strategy
Switch(config)# policy-map user1-up //definition PC1 uplink rate is 1M
Switch(config-pmap)# class user1-up
Switch(config-pmap-c)# trust dscp
Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop
Switch(config)# policy-map user2-up // definition PC1 uplink rate is 2M
Switch(config-pmap)# class user2-up
Switch(config-pmap-c)# trust dscp
Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop
Switch(config)# policy-map user-down
Switch(config-pmap)# class user1-down
Switch(config-pmap-c)# trust dscp
Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop
Switch(config-pmap-c)# exit
Switch(config-pmap)# class user2-down
Switch(config-pmap-c)# trust dscp
Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop
Switch(config-pmap-c)# exit
 
5 Strategy on the interface
Switch(config)# interface f0/1
Switch(config-if)# service-policy input user1-up
Switch(config)# interface f0/2
Switch(config-if)# service-policy input user2-up
Switch(config)# interface g0/1
Switch(config-if)# service-policy input user-down



share on: Share it! Tweet it! Stumble it! Digg it! Email it!  |  Permalink  |  cisco2900router in Cisco 3750 | Comment on this
Reader Comments

Post a Comment
Author:
Email:
(Optional)
  
cisco2900router
Reputation: 0 (0%)
Member Since:  Jan 2014
Last activity: 5/18/15, 12:38 am